Alerting

udp://514 input exclusion

joeybroesky
Path Finder

We have logs coming in udp port 514 and want to exclude indexing events with the field "action" equaling "accept". We have tried inserting the following into the inputs.conf but does not work.

blacklist = action = "accept"

Please assist.

Labels (1)
Tags (2)
0 Karma
1 Solution

venkatasri
Influencer

Hi @joeybroesky 

There seems no blacklist setting exist as per inputs conf - inputs.conf - Splunk Documentation

You can send the events to nullQueue to avoid indexing apply the following conf on HF/indexer. 

#props.conf
[your_udp_sourcetype/source::<source>/host::<hostname>]
TRANSFORMS-null= setnull
 
#transforms.conf
[setnull]
REGEX = action\s+=\s+\"accept\"
DEST_KEY = queue
FORMAT = nullQueue

 ----

An upvote would be appreciated and accept solution if it helps!

 

View solution in original post

venkatasri
Influencer

Hi @joeybroesky 

There seems no blacklist setting exist as per inputs conf - inputs.conf - Splunk Documentation

You can send the events to nullQueue to avoid indexing apply the following conf on HF/indexer. 

#props.conf
[your_udp_sourcetype/source::<source>/host::<hostname>]
TRANSFORMS-null= setnull
 
#transforms.conf
[setnull]
REGEX = action\s+=\s+\"accept\"
DEST_KEY = queue
FORMAT = nullQueue

 ----

An upvote would be appreciated and accept solution if it helps!

 

View solution in original post

joeybroesky
Path Finder

Thanks for your help! This did exactly what I was looking for.

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!