Alerting

Why is my scheduled alert not sending email?

DerekB
Splunk Employee
Splunk Employee

I have a scheduled alert configured and I am not receiving any email from it. The search is valid and matches records. I have the proper permissions. Alert history shows 'successful' result and job inspection shows e-mail was sent.

Where is my email?

0 Karma

rakeshh123
Path Finder

OK
first U have to go to server settings and check if SSL is enabled in Splunk Web ....... if not enable it...Restart it
If u r not getting mail after restart then go to
1.Gmail --------> Settings -----------> Forwarding and POP/IMAP---------> IMAP Access------>
IMAP Access: enable it ......

  1. Gmail --------> Myaccount -----------> Sign-in & security----------> Connected apps & sites------> Allow less secure apps: enable it .......

DerekB
Splunk Employee
Splunk Employee

Check your TLS setting.

In this case, it was found that the "TLS" delivery had been set for email settings. No credentials or target defined.

Reset the TLS delivery to "none" and that restored e-mail flow from Search Head

0 Karma

gyslainlatsa
Motivator

hi DerekB,

you use what operating system?

0 Karma

DerekB
Splunk Employee
Splunk Employee

Ubuntu was the OS.

0 Karma
Get Updates on the Splunk Community!

Detecting Remote Code Executions With the Splunk Threat Research Team

WATCH NOWRemote code execution (RCE) vulnerabilities pose a significant risk to organizations. If exploited, ...

Enter the Splunk Community Dashboard Challenge for Your Chance to Win!

The Splunk Community Dashboard Challenge is underway! This is your chance to showcase your skills in creating ...

.conf24 | Session Scheduler is Live!!

.conf24 is happening June 11 - 14 in Las Vegas, and we are thrilled to announce that the conference catalog ...