Alerting

Setup alert on inactivity

dhirajjain
New Member

Hi,

I want to setup an alert in SPLUNK where it gives me an alarm when there is no log for 15 mins.

Please guide me

Thanks
DJ

Tags (2)
0 Karma

martin_mueller
SplunkTrust
SplunkTrust

First, you should take a look at http://docs.splunk.com/Documentation/Splunk/5.0.3/Alert/Aboutalerts

After that, define a search that looks for your logs - maybe something like this:

index=foo sourcetype=bar field=baz | stats count

Create an alert for that, scheduled to run every fifteen minutes over a fifteen minute timerange, triggered if count is zero. If you're confident to have delays less than five minutes your timerange could be -5m to -20m, and your cron schedule could be */15 * * * *.

carfield
New Member

Can I search for multiple log files, and group by each file, then alert if either one of the files don't update?

0 Karma

isoutamo
SplunkTrust
SplunkTrust
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...