Alerting

How to create a splunk alert if the user login to splunk via local credential using Splunk login type?

mala_fmr
Engager

Hi, 

We have 2 Splunk authentication systems - SAML,Splunk (default). We wanted to have an alert, if the user login to Splunk via "Splunk" authentication system.

Is there way to do that? Can we do this via Splunk query?
need help on this.

Thanks,

Mala S

Labels (2)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

That's in the audit logs.

index=_audit info=succeeded method=Splunk user!=internal_observability
---
If this reply helps you, Karma would be appreciated.

starcher
Influencer

with some cleanup since Splunk can't onboard their own audit logs.

index=_audit info=succeeded method=Splunk user!=internal_observability
| rename useragent as http_user_agent
| eval signature=reason." local splunk user login", src=coalesce(clientip,"unknown"), session_id=session
| iplocation prefix=src_ src
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Splunk Community Badges!

  Hey everyone! Ready to earn some serious bragging rights in the community? Along with our existing badges ...

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...

Design, Compete, Win: Submit Your Best Splunk Dashboards for a .conf26 Pass

Hello Splunkers,  We’re excited to kick off a Splunk Dashboard contest! We know that dashboards are a primary ...