Alerting

Alerting per device

corwinz6
Explorer

Hello,

I have about 80 devices logging to Splunk and am in the process of trying to setup alerting for them. I would like for alerts to go off individually for each device when a event occurs. Is this possible without setting up alerts specific for each device? i.e. I have a search that runs every 5 minutes looking at the logs for the previous 6 minutes with:

sourcetype=fortinet type=event status=failed and a custom condition of | stats count(Mgmt_IP) as attempts by devname | where attempts > 2 

so that I am only looking at devices with a frequency of more than 2 login failures in the last 6 minutes. I know if I say devname=X in the search this will work, but I'd like to avoid having to create hundreds of alerts.

Tags (1)
1 Solution

Ledion_Bitincka
Splunk Employee
Splunk Employee

Currently this is not possible - we are working on per result alerting and you should get your hands on it during our next major release (going into beta soon). In the mean time you can either process the search results inside your script (if using scripted alerts) or modify the sendemail search command to send out one email per result, see this for more info on how to modify sendemail

View solution in original post

Ledion_Bitincka
Splunk Employee
Splunk Employee

Currently this is not possible - we are working on per result alerting and you should get your hands on it during our next major release (going into beta soon). In the mean time you can either process the search results inside your script (if using scripted alerts) or modify the sendemail search command to send out one email per result, see this for more info on how to modify sendemail

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...