Alerting

Alert when service is down on multiple hosts

fsrodriguez
New Member

I have the Splunk Add-On for Linux and Unix installed which enables the "PS" command. How can I monitor the tomcat service or some other service on multiple hosts for 5 minutes?

This is what I have so far:

host="server-*" source="ps" tomcat

I would like to trigger an alarm whenever the tomcat service has been down for more than 5 minutes on any of the hosts that the query finds.

0 Karma

Yunagi
Communicator

Try the following search:

host="server-*" source="ps" process_name="tomcat" | dedup host | eval lastseen=now()-_time

You might need to change process_name="tomcat" to suit your needs. You also might want to add "index=..." This will make your searches faster.

Save this search as an alert with the custom trigger condition: lastseen>300. The time range should be several hours, e.g. last 24 hours.

0 Karma

fsrodriguez
New Member

when you say "You also might want to add "index=...""....

This means setting up a monitor this way:

splunk add monitor /opt/tomcat/logs/catalina.out  -index tomcat

Right?

and then do:

 host="server-*" source="tomcat" process_name="tomcat" | dedup host | eval lastseen=now()-_time
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Mastering Threat Intelligence in ES 8.5, Splunk AI Assistant v2, and More from Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

Break the Build: Inside the KubeDoom Lounge at .conf26

    You step up to the machine. The pixelated corridors of a certain 1993 FPS load in front of you, EMP Pulse ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...