Alerting

Alert based on sum(time)

aniketb
Path Finder

Hi,

I have a query for 1 hour as:

"Search String" sourcetype="XX" source="XX" | stats sum(time) by host

I have 2 hosts and i see

host1 28.7
host2 45.9

I need to set an alert if any of these host values reach 100. Any pointers?

Tags (3)
0 Karma
1 Solution

BobM
Builder

You can use where to filter the results

"Search String" sourcetype="XX" source="XX" | stats sum(time) as duration by host | where duration >= 100

Or if you wan to keep the smaller results you can set a custom condition in the alert settingss to be

where duration >= 100

View solution in original post

0 Karma

BobM
Builder

You can use where to filter the results

"Search String" sourcetype="XX" source="XX" | stats sum(time) as duration by host | where duration >= 100

Or if you wan to keep the smaller results you can set a custom condition in the alert settingss to be

where duration >= 100
0 Karma

aniketb
Path Finder

Thanks BobM!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...