Splunk Search

Check events in time

noott211
Path Finder

index="fw" app="ping"
| bin _time span=10m
| stats count by client_ip,dest_ip
| stats list(dest_ip) AS dest_ip , list(count) AS count by client_ip
| table client_ip , dest_ip , count


I'd like to check the origin IP and destination IP that I pinged 10 times in 10 minutes.
However, this command calculates the number of times for all times.
Give me a hand with this.

Labels (1)
Tags (2)
0 Karma
1 Solution

ITWhisperer
SplunkTrust
SplunkTrust

You need to include _time in the stats commands

index="fw" app="ping"
| bin _time span=10m
| stats count by _time,client_ip,dest_ip
| stats list(dest_ip) AS dest_ip , list(count) AS count by _time,client_ip
| table _time, client_ip , dest_ip , count

View solution in original post

0 Karma

ITWhisperer
SplunkTrust
SplunkTrust

You need to include _time in the stats commands

index="fw" app="ping"
| bin _time span=10m
| stats count by _time,client_ip,dest_ip
| stats list(dest_ip) AS dest_ip , list(count) AS count by _time,client_ip
| table _time, client_ip , dest_ip , count
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Rounding off the Splunk Dashboard Contest

What does a contest-winning Splunk dashboard look like? In this case, it isn't in a browser tab at all. It ...

A Four Part Event Series: AI + Observability: AI Agents, LLMs, Apps, & Infrastructure

AI + Observability: AI Agents, LLMs, Apps, & Infrastructure The rapid evolution of artificial intelligence ...

Splunk Technical Support Is Moving to Cisco Support Tools

Introduction Splunk technical support is transitioning to Cisco’s support environment. This change brings ...