Yes, the result is immediate as long as you refresh/reload the search. The lookup does not impact or change any data in the datamodel, so no rebuild necessary. One caveat is that if you're summarizing data, you need to first summarize it at an small enough time interval that matches the granularity of your maintenance window, e.g. if your maintenance window is typically 30 minute block increments, you should set the tstat span=30m, then run the lookup to filter result, and then run stats to summarize by day. | tstats span=1h summariesonly=true allow_old_summaries=true count(device.status) as count from datamodel=Devices.device where device.status!="" AND device.customer="*" AND device.device_id ="*" by device.customer, device.device_id, device.name, device.status _time
| eval excluded=1
| lookup exclude_maintenance_window_lookup excluded OUTPUT end
| eval end_time=strptime(end, "%Y-%m-%dT%H:%M:%S.%3N%z")
| where _time<end_time
| bucket _time span=1d
| rename device.customer AS device_customer device.device_id AS device_id device.name AS device_name device.status AS device_status
| stats sum(count) AS count BY _time device_customer device_id device_name device_status
... View more