My dashboard is based on a datamodel but it has drilldowns to the actual logs
If I have a multiselect for actions (A, B, C), I can set the valuePrefix with a delimiter of "OR"
<input type="multiselect" token="form_action">
<label>Action</label>
<choice value="=A">A</choice>
<choice value="=B">B</choice>
<choice value="=C">C</choice>
<prefix>(</prefix>
<suffix>)</suffix>
<valuePrefix>DataModel.action</valuePrefix>
<delimiter> OR </delimiter>
<default>=A,=B</default>
<initialValue>=A,=B</initialValue>
</input>
So that based on selections, I can define DataModel search terms to
DataModel.action=A OR DataModel.action=B
However the actual event log does not have the field DataModel.action. It only has "action". So when I do a drilldown to the log events, I would like to be able so drill down to a search that includes
action=A OR action=B
The two ideas that I have to do this are
rename the prefix to just "action" and delay my datamodel search terms until after I have selected from my datamodel:
|tstats count from datamode=DataModel by DataModel.action | eval action=DataModel.action | search $form_action$
create field alias for my log source field action called DataModel.action then searches for DataModel.action should work
IMO, the first option is bad because it does not allow further variation in log sources. So if I had visualizations that might drill down to different log sources, with different field names for "action", I could not create those drill downs
The second option is slightly better but I would also not like to start creating aliases for logs source to match data models
Is there a better way to do this?
... View more