Splunk Search

unique values

rcbutterfield
Explorer

Hello Splunk People....

I want to return a search within splunk.  THe index is wineventlogs and i want to return all the eventcodes within eventtypes.  

Meaning.... 

Eventtype A includes eventcode 5144, 5145, 5146

Eventtype b includes eventcode 5144, 5166, 5167

As examples....   thanks to all

Labels (1)
0 Karma
1 Solution

gcusello
SplunkTrust
SplunkTrust

Hi @rcbutterfield ,

you should try something like this:

index=wineventlog
| stats
     values(EventCode) AS EventCode
     count
     By eventtype

Ciao.

Giuseppe

View solution in original post

gcusello
SplunkTrust
SplunkTrust

Hi @rcbutterfield ,

you should try something like this:

index=wineventlog
| stats
     values(EventCode) AS EventCode
     count
     By eventtype

Ciao.

Giuseppe

rcbutterfield
Explorer

Thank you!  it works perfect! 

0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @rcbutterfield ,

good for you, see next time!

Ciao and happy splunking

Giuseppe

P.S.: Karma Points are appreciated 😉

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Observability Simplified: Combining User Experience, Application Performance & ...

Tech Talk Observability Simplified: Combining User Experience, Application Performance & Network ...

Event Series May & June: From Network Visibility to Service Intelligence

Unifying the Network: Moving from Alert Noise to Service Intelligence with Splunk ITSI In today’s hybrid ...

Global Splunk User Group Events: May + June 2026

Your Splunk Community Awaits: Discover Upcoming User Group Events Worldwide    Staying ahead in the fast-paced ...