Splunk Search

subsearch semantics

igorbukanov
Engager

I was trying to figure out why my search with subsearch does not work and then I realized that exact semantics of the subsearch is not clear for me.

Consider the following search:

( ( t="*my_substring*" ) )

This works and generates a number of results. Then consider the following search:

*| eval t="*my_substring*" | head 1 | fields t | format

It generates:

( ( t="*my_substring*" ) )

That is, I got the same text that I used for the first search. Now I combine both:

[search *| eval t="*my_substring*" | head 1 | fields t]

This gives 0 results. Why? I thought the subsearch result are formated using an implicit format and then the outer search is running with [...] literally replaced with that result string.

Tags (1)

reed_kelly
Contributor

I didn't have a problem with it. I also changed the search to use gentimes for performance reasons (it doesn't need to hit indexes). Here is my subquery example:

index=_internal [gentimes start=1/1/00 end=1/2/00|eval user="*kelly*"|fields user]
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...