Splunk Search

splunk search query

kajalchopade071
Path Finder

suppose if i have user1,user2,user3 i need to find out last log message of each user h

Labels (2)
0 Karma
1 Solution

isoutamo
SplunkTrust
SplunkTrust

Hi

expecting that your log message is in field named message

index=<your index>
| stats last(message) by user
| where user IN ("user1", "user2", "user3")

Based on amount of your user etc. it could be better to switch where before stats.

r. Ismo 

View solution in original post

isoutamo
SplunkTrust
SplunkTrust

Hi

expecting that your log message is in field named message

index=<your index>
| stats last(message) by user
| where user IN ("user1", "user2", "user3")

Based on amount of your user etc. it could be better to switch where before stats.

r. Ismo 

kajalchopade071
Path Finder

suppose if i have lots of user not only 3 user so how can i used by using IN

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...