Splunk Search

problem in query

kuldeepsingh99
New Member

I am using this query to get the Percentage CPU Utilization.

index=os sourcetype="cpu" minutesago=15 | eval human_readable_time=strftime(_time, "%Y-%d-%m %H:%M:%S") |
table host, human_readable_time, pctUser, pctIdle

It work fine on Splunk 4.5 version but i am not getting data on 4.2.3 version, i am not getting data for pctUser and pctIdle fields

Kindly Help

Tags (1)
0 Karma

MarioM
Motivator

He meant Splunk for Unix/Linux app v4.5

0 Karma

rajiv_kumar
Path Finder

It is working fine.

Thanks,
Rajiv

0 Karma

MarioM
Motivator

great! then if you could accept the answer it will be useful for other with same issue.

0 Karma

MarioM
Motivator

i used the following to get it to work on 4.5:

index=os sourcetype="cpu" minutesago=15 | multikv forceheader=1 | eval human_readable_time=strftime(_time, "%Y-%d-%m %H:%M:%S") | table host, human_readable_time, pctUser, pctIdle
0 Karma

ChrisG
Splunk Employee
Splunk Employee

Which version of Splunk are you running? 4.3.1 is the latest.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...