Splunk Search

pipeline as first character in search query

kkkelvinkk
New Member

Hi all,

I would like to ask what is the meaning of using pipeline as first character in search query. I saw some video tutorial that will use pipeline as first character and also correlation search in enterprise security.
Thanks all.

0 Karma
1 Solution

DalJeanis
Legend

It depends on the kind of verb you use.

If there is no pipeline character first, then the implied verb is "search". Every other verb which is a "generating command" requires the pipeline character before the verb.

http://docs.splunk.com/Splexicon:Generatingcommand

View solution in original post

0 Karma

kkkelvinkk
New Member

Below is the search query I extracted from Enterprise Security:

| tstats allow_old_summaries=true count as change_count from datamodel=Change_Analysis.All_Changes by All_Changes.user,All_Changes.change_type | drop_dm_object_name("All_Changes") | xswhere change_count from change_count_by_user_by_change_type_1d in change_analysis by change_type is above high

From my understanding, some data is search and then pipeline to "generating command". So, what is being passed as argument from the above search query ? I mean the pipeline being putting as the first character. Or it is just the correct syntax to use splunk ?

0 Karma

masonmorales
Influencer

This answer has a good explanation. I would add that a pipe must precede all search commands.

0 Karma

DalJeanis
Legend

Mason - The phrase "all search commands" is ambiguous and might mislead some readers... especially since the implicit search at the start of any search query is the main exception...

0 Karma

masonmorales
Influencer

Splunk Docs and the Quick Reference Guide all say, "search commands", so I believe I am using proper nomenclature here.

0 Karma

DalJeanis
Legend

It depends on the kind of verb you use.

If there is no pipeline character first, then the implied verb is "search". Every other verb which is a "generating command" requires the pipeline character before the verb.

http://docs.splunk.com/Splexicon:Generatingcommand

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...

SPL2 Deep Dives, AppDynamics Integrations, SAML Made Simple and Much More on Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...