Splunk Search

loadjob command has issues with colons in my saved search name?

the_wolverine
Champion

I've got a saved search name with colons, like this:

savedsearch_name="Mysearch: has a colon"

The loadjob command doesn't seem to like it and I can't figure out how to make it work other than to rename my search to something without spaces:

" | loadjob "admin:search:Mysearch:
has a colon"

Splunk (5.0.3) reports:

"Error in 'loadjob' command: Option
'savedsearch_name=admin:search:Mysearch:
has a colon' is invalid.

0 Karma
1 Solution

the_wolverine
Champion

Yes, the loadjob command has an issue with colons. Not sure about any other characters. It would be nice to have this documented so I can name my searches in a manner that they can be used with the loadjob command.

View solution in original post

the_wolverine
Champion

Yes, the loadjob command has an issue with colons. Not sure about any other characters. It would be nice to have this documented so I can name my searches in a manner that they can be used with the loadjob command.

the_wolverine
Champion

filed a bug with Splunk.

0 Karma

laserval
Communicator

Agreeing with @somesoni2, spaces should not be a problem in loadjob. Try it without the colon. I use dashes in my saved searches .

0 Karma

somesoni2
SplunkTrust
SplunkTrust

I believe renaming is the only options here. It seems loadjob doesn't support object name containing colon or semicolon. Spaces works fine.

Get Updates on the Splunk Community!

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...

Splunkbase | Splunk Dashboard Examples App for SimpleXML End of Life

The Splunk Dashboard Examples App for SimpleXML will reach end of support on Dec 19, 2024, after which no new ...

Understanding Generative AI Techniques and Their Application in Cybersecurity

Watch On-Demand Artificial intelligence is the talk of the town nowadays, with industries of all kinds ...