Splunk Search

group certain URLs

gerard11
Engager

I have a search that returns events with many different URLs

 

 

index=test URL=*

 

 

I want to obtain a count of events per URL

However some of the URLs are slightly different so I want to group them together

Example of my URL values

/login/
/login/
/api/customer/5542-a44/data
/api/customer/5c77-59w/data
/api/customer/7a88-134/data
/weather/forecast/
/api/savedseach/7775
/api/savedseach/4788
/new/user

What I would like to end up with

URLCOUNT
/login/2
/api/customer//data3

/weather/forecast/

1

/api/savedseach/

2

/new/user

1

 

Im using | stats count by URL
However as mentioned above my issue is with the URLs that have ids or guids in them

Labels (1)
0 Karma
1 Solution

dmarling
Builder

You can normalize the url with regular expression, but you will need to account for all of your use cases.  Here's an example regex based on the examples you provided:

| rex mode=sed field=URL "s/\/(customer|savedsearch)\/[^\e\/]+/\/\1\//g"

 

Here's a run anywhere example that shows how it works:

| makeresults
| eval URL="/login/
/login/
/api/customer/5542-a44/data
/api/customer/5c77-59w/data
/api/customer/7a88-134/data
/weather/forecast/
/api/savedsearch/7775
/api/savedsearch/4788
/new/use"
| makemv URL tokenizer="(?<URL>[^\n]+)"
| mvexpand URL
| rex mode=sed field=URL "s/\/(customer|savedsearch)\/[^\e\/]+/\/\1\//g"
| stats count by URL
If this comment/answer was helpful, please up vote it. Thank you.

View solution in original post

0 Karma

dmarling
Builder

You can normalize the url with regular expression, but you will need to account for all of your use cases.  Here's an example regex based on the examples you provided:

| rex mode=sed field=URL "s/\/(customer|savedsearch)\/[^\e\/]+/\/\1\//g"

 

Here's a run anywhere example that shows how it works:

| makeresults
| eval URL="/login/
/login/
/api/customer/5542-a44/data
/api/customer/5c77-59w/data
/api/customer/7a88-134/data
/weather/forecast/
/api/savedsearch/7775
/api/savedsearch/4788
/new/use"
| makemv URL tokenizer="(?<URL>[^\n]+)"
| mvexpand URL
| rex mode=sed field=URL "s/\/(customer|savedsearch)\/[^\e\/]+/\/\1\//g"
| stats count by URL
If this comment/answer was helpful, please up vote it. Thank you.
0 Karma

gerard11
Engager

This is exactly what I was looking for, thank you.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...