Splunk Search

generate external url links from search

jalfrey
Communicator

I have a simple search with an eval that generates a valid HTML link:

index=sonicwall "TemplateID=265" | eval support_url=("http://software.sonicwall.com/applications/gav/index.asp?ev=v&v_id=" + signature_id)

How do I make so clicking on the link will follow it instead of adding it to search?

Tags (3)
0 Karma

jbrodsky_splunk
Splunk Employee
Splunk Employee

While you won't be able to drill into the field directly in the search results, you can follow the instructions in the link below to add a workflow action. Since the field is already in the form of a URL, use the special prefix "$!" as described near the bottom of that page.

workflow actions

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...