Splunk Search

gaps in line graph

jedatt01
Builder

I have an advanced xml view set up with some line graphs, but it seems that on the graphs that do not have a large data set, it shows gaps in the graph. Also I can click around the chart area and sometimes find plot points in the middle of nowhere. What could be causing this?

Tags (3)
1 Solution

gkanapathy
Splunk Employee
Splunk Employee

You need to set the line chart property/param charting.chart.nullValueMode to connect instead of the default of gaps and/or you need to set charting.chart.showMarkers to true:

<param name="charting.legend.nullValueMode">connect</param>
<param name="charting.legend.showMarkers">true</param>

http://docs.splunk.com/Documentation/Splunk/4.2.3/Developer/CustomChartingConfig-ChartLegend#Chart

View solution in original post

ranjyotiprakash
Communicator

Even though I am using the same thing my line graph is not going to zero for null values and it is showing gaps . Please help..

0 Karma

splunker12er
Motivator
<param name="charting.legend.nullValueMode">zero</param>
<param name="charting.legend.showMarkers">true</param>

this would help..

0 Karma

gkanapathy
Splunk Employee
Splunk Employee

You need to set the line chart property/param charting.chart.nullValueMode to connect instead of the default of gaps and/or you need to set charting.chart.showMarkers to true:

<param name="charting.legend.nullValueMode">connect</param>
<param name="charting.legend.showMarkers">true</param>

http://docs.splunk.com/Documentation/Splunk/4.2.3/Developer/CustomChartingConfig-ChartLegend#Chart

View solution in original post

jedatt01
Builder

That worked perfectly! Thanks

0 Karma

NeerajDhapola7
Path Finder

Below worked for me instead of PARAM

        <option name="charting.chart.nullValueMode">connect</option>
         <option name="charting.chart.showMarkers">true</option>
0 Karma
Take the 2021 Splunk Career Survey

Help us learn about how Splunk has
impacted your career by taking the 2021 Splunk Career Survey.

Earn $50 in Amazon cash!