Splunk Search

events not showing

sulaimancds
Engager

| tstats summariesonly=true max(_time) as lastTime, count FROM datamodel=Change BY "All_Changes.action", "All_Changes.result_id", "All_Changes.user", "All_Changes.dest" | rename "All_Changes.*" as * | search result_id = 4732 | convert ctime(lastTime) as lastTime

 

i am running this command , there is output , but i want to see events and know more details , but events not showing

 

total number of events Complete 590,046 events

Labels (1)
0 Karma

VatsalJagani
SplunkTrust
SplunkTrust

@sulaimancds - tstats command does not search events, as it is built for performance and not for showing events. Use datamodel command instead or a regular search.

| datamodel Change All_Changes search strict_fields=false

 

Kindly upvote if you find this answer useful!!!

0 Karma

sulaimancds
Engager

hi please provide me the full command

Tags (1)
0 Karma

VatsalJagani
SplunkTrust
SplunkTrust

@sulaimancds  - Try this as a full search and run it in "Verbose mode".

| datamodel Change All_Changes search strict_fields=false | search "All_Changes.result_id"=4732
  •  This will show the events as you asked.

 

But if you need events as well as the results then do a regular search in "Verbose mode".

index=* tag=change | stats max(_time) as lastTime, count BY action, result_id, user, dest
| search result_id = 4732 
| convert ctime(lastTime) as lastTime

 

Kindly accept the answer and upvote if this helps you!!!

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...