Splunk Search

df by host,mount

cmeo
Contributor

I'm trying to set up a timechart of disk free by host and mountpoint and this is proving difficult, because timechart will only accept one field for a by clause. This doesn't work because the level of uniqueness is host,mount not host or mount. Let me additionally say I loathed the new version of the NIX app on sight and can't stand the new visualisations. The old versions--which I can't download any more for pointers--did the job fine in my opinion. So all I want is for something like this to work:

sourcetype=df| timechart span=1h avg(storage_percent_free) AS pctfree by host, mount

and make a nice, old school line chart which you can extrapolate easily...like the old version did.

Anyone know how I get there?

Tags (2)
0 Karma

jbrodsky_splunk
Splunk Employee
Splunk Employee

Or something like this?

sourcetype=df index=os | eval hostmount=host.":".mount | timechart avg(storage_free_percent) by hostmount usenull=f

MuS
SplunkTrust
SplunkTrust

Hi cmeo,

you can use chart instead to do this:

 sourcetype=df | chart span=1h values(mount) AS mount avg(storage_percent_free) AS pctfree over _time by host

should do the job for you.

cheers, MuS

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...