Splunk Search

chart query

DTERM
Contributor

The following query

index=test | top Hostname

produces a chart that has percentages included in the chart along with the top hostnames. How do I not include the percentages in the chart? I do not want percentages in the chart.

Tags (1)
0 Karma
1 Solution

ahall_splunk
Splunk Employee
Splunk Employee

The showperc modifier to the top command is what you want. Here is how you use it:

index=test | top showperc=false Hostname

View solution in original post

0 Karma

ahall_splunk
Splunk Employee
Splunk Employee

The showperc modifier to the top command is what you want. Here is how you use it:

index=test | top showperc=false Hostname
0 Karma

Greg_LeBlanc
Path Finder

You can do:

index=test 
| stats count(_raw) as topHostnames by Hostname 
| sort - topHostnames
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...