Splunk Search

case-sensitive on subsearch

simo
Path Finder

hi

I have this situation

index="idx" [| inputlookup name.csv | table id name ]

idx=

idname
1a2aaa
1A2aaa
12abbb

 

lookup

idname
1a2

aaa

 

the result is that it extracts the first 2 lines. How do I extract just the first line?

Thank you

Simone

Labels (1)
0 Karma
1 Solution

ITWhisperer
SplunkTrust
SplunkTrust

Try something like this

index="idx" 
| where [| inputlookup name.csv | table id name ]

View solution in original post

ITWhisperer
SplunkTrust
SplunkTrust

Try something like this

index="idx" 
| where [| inputlookup name.csv | table id name ]
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...