Splunk Search

Why query works in my own app, but not Search and Reporting app?

splunkbeginner2
Path Finder

Hi,

I am having trouble with a query. It works in my own app, which I created with the Splunk -> Manage Apps, new App.. some weeks ago.
When I am trying to run this query now in the search and reporting app, the events were shown, but no graph or statistic table gets generated for exactly the same query.

I already checked the following:
The SNMP Source is used by the app "launcher", not my app! and the index was created by the app "search".

Why couldn't I see my timechart for those events in the search and reports app?

Thank you for your support!

Kind regards,
Xantor

Tags (3)
0 Karma
1 Solution

mcronkrite
Splunk Employee
Splunk Employee

Sounds like your app has "private" field extractions. Go to the Settings - Fields area, and check under field extractions. Make sure the ones from the SNMP app are set to global permissions.

View solution in original post

mcronkrite
Splunk Employee
Splunk Employee

Sounds like your app has "private" field extractions. Go to the Settings - Fields area, and check under field extractions. Make sure the ones from the SNMP app are set to global permissions.

View solution in original post

splunkbeginner2
Path Finder

ah yes, that it was, I totally forgot to check my fields 😕 Thank you!

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!