Splunk Search

Why is tstats aggragate function not returning results?

lnvaderzee
Loves-to-Learn

So I'm fairly new to using data models for my visuals, and converting my network performance dashboard to summarized data model searched. My visuals for error rate and request volume worked easily, but latency not so much. Here's the search I am attempting:

| tstats summariesonly=t avg(All_Performance.Network.latency) from datamodel=Performance.All_Performance where nodename=All_Performance.Network BY _time span=15s

 

here are searches that work:

| tstats summariesonly=t count(All_Performance.Network.latency) from datamodel=Performance.All_Performance where nodename=All_Performance.Network BY _time span=15s

 

| from datamodel Performance.Network | timechart span=15s avg(latency) as latency

 

Can someone explain why tstats count() works here, but not min, avg, max, etc?

Labels (2)
0 Karma

somesoni2
Revered Legend

Check datamodel definition to see the data type for the field Latency whether it's a number or string. Avg works with numbers.

0 Karma

lnvaderzee
Loves-to-Learn

That was actually my first thought. I checked and when I made the field I did in fact have it as string, but changed it and rebuilt the acceleration. So it wasn't that

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Observability Simplified: Combining User Experience, Application Performance & ...

Tech Talk Observability Simplified: Combining User Experience, Application Performance & Network ...

Event Series May & June: From Network Visibility to Service Intelligence

Unifying the Network: Moving from Alert Noise to Service Intelligence with Splunk ITSI In today’s hybrid ...