Splunk Search

Why is tstats aggragate function not returning results?

lnvaderzee
Loves-to-Learn

So I'm fairly new to using data models for my visuals, and converting my network performance dashboard to summarized data model searched. My visuals for error rate and request volume worked easily, but latency not so much. Here's the search I am attempting:

| tstats summariesonly=t avg(All_Performance.Network.latency) from datamodel=Performance.All_Performance where nodename=All_Performance.Network BY _time span=15s

 

here are searches that work:

| tstats summariesonly=t count(All_Performance.Network.latency) from datamodel=Performance.All_Performance where nodename=All_Performance.Network BY _time span=15s

 

| from datamodel Performance.Network | timechart span=15s avg(latency) as latency

 

Can someone explain why tstats count() works here, but not min, avg, max, etc?

Labels (2)
0 Karma

somesoni2
Revered Legend

Check datamodel definition to see the data type for the field Latency whether it's a number or string. Avg works with numbers.

0 Karma

lnvaderzee
Loves-to-Learn

That was actually my first thought. I checked and when I made the field I did in fact have it as string, but changed it and rebuilt the acceleration. So it wasn't that

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

How much can you really learn in 3 minutes?

Observability can certainly be hard to understand – there's a lot of jargon and buzzwords and it seems to ...

Event Series: The Agentic SOC: Trust Before Autonomy

AI is fundamentally changing security operations, but true progress requires more than just automation—it ...

Free Professional Services for .conf26 Attendees

This year at .conf26, we are doing something a little different. We are bringing the best minds from ...