Splunk Search

Why is my search stuck in "Finalizing job..." status and does not return any results with Internet Explorer (IE11)?

_smp_
Builder

Hello. I just finished upgrading from 6.3.3 to 6.5.1 last night. This morning, I am able to reproduce a problem where a search will hang in the "Finalizing job..." state in IE (Internet Explorer) version 11.0.9600.18537CO. Another thing of note is that there are zero results returned, although I know based on my search (and by performing the same search in Chrome) that there are events that should be matched. The Inspect Job page also hangs at "Loading...". I have reproduced this on two machines that have both cleared their caches.

Any idea on how to debug this?

0 Karma
1 Solution

ddrillic
Ultra Champion
0 Karma

eric_kruse
Engager

Hit Shift-F5 on the search page. Was browser cache for us.

_smp_
Builder

Yes, Shift-F5 also fixed it for me. But importantly, deleting the IE cache using the Internet Options dialog box did not.

0 Karma

ddrillic
Ultra Champion
0 Karma

_smp_
Builder

I cleared my browser cache and this did not fix it. But somewhere in that thread someone made the comment of holding the control key while refreshing the page in Chrome. I tried holding the shift key in IE, and that seems to have resolved it.

0 Karma

ddrillic
Ultra Champion

Great news!!!

0 Karma

arkadyz1
Builder

One of the things that helped our company in the past was adding minify_js=False in [settings] stanza in web.conf. The overhead is sending some additional spaces, tabs and new lines along with the rest of JavaScript code, which is minimal. But the issue might just go away, and even if not, it will be easier to debug on the client side.

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.