I find this very ridiculous considering that the terminology used is not accurate in what it is doing. When doing a search to hide data from being searchable, it calls it delete. Well it's not deleting the data from the logs so its essentially a misnomer calling the function delete. Instead either call it hide or removeFromSearch - some other name that gives it meaning.
I've spent the last 2 hours searching how to reclaim disk space without removing the primary index - its not possible and people have been requesting this kind of utility for years! Naming conventions mean a lot. They carry a lot of meaning and seeing this kind of misnomer is really frustrating.