Splunk Search

Why is Field Alias not applying?

joshuasolman
Loves-to-Learn Everything

Hey all, 

When i run a search like this: 

 

 

 

index=crowdstrike_pci sourcetype=crowdstrike:events:sensor event_simpleName=FileIntegrityMonitorRuleMatched | rename CommandLine AS process ContextTimeStamp AS file_access_time ImageFileName AS file_path ObjectName AS file_name ParentBaseFileName AS parent_process_exec ParentBaseFileName AS parent_process_name ParentCommandLine AS parent_process ParentImageFileName AS parent_process_path ParentProcessId AS parent_process_id RawProcessId AS process_id SHA256HashData AS file_hash UserName AS user aip AS dest event_platform AS os

 

 

 

 

The fields populate correctly, but when i hit up the Field Alias settings in the GUI to make them permanent, they dont appear in the search. Permissions are set for everyone to read all, and for sc_admin to write them. Its Splunk Cloud so i dont have access to the props.conf unless i upload one myself, but the field alias works for other sourcetypes, just not this one. 

Any ideas?

 

Labels (2)
0 Karma

dannymcdonald
Observer

Check the TA default configs or anything else for field aliases or evals that have the same name i.e. FIELDALIAS-user and EVAL-user in props or GUI. Either remove the duplicate field alias or eval, or rename them like FIELDALIAS-userTest and see if the new field pops up. I know the Crowdstrike TA 3.1.6 has duplicate names for user and severity which causes Splunk to drop the alias or eval altogether

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Tiling

This puzzle (first published here) is based on finding groups of tessellated tiles (inspired by floor tiles I ...

SOK it to Me: Top 3 Benefits of Using Splunk Operator on Kubernetes that’ll Make ...

    Thursday, July 9, 2026  |  11:00AM–12:00PM PDT Duration: 1 hour (includes Q&A) Managing can feel like a ...

Upgrade Prep for 10.4, Network Observability Deep Dives, and More from Splunk Lantern

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...