Splunk Search

Why is Datamodel=Authentication not getting older events?

mlm
Explorer

Hey gents,

 I am very new to splunk but does anyone have an idea why my search from datamodel=authentication not getting older events (say last month or two)? Below is my search string:

| tstats prestats=true summariesonly=true allow_old_summaries=true count from datamodel=Authentication.Authentication where Authentication.app=win* Authentication.action=* by _time, Authentication.action span=10m
| timechart minspan=10m useother=true count by Authentication.action



Any suggestion would be so much appreciated! 


Cheers 

Labels (2)
0 Karma

PickleRick
SplunkTrust
SplunkTrust

You can either disable acceleration, change the summary range and rebuild the summaries (which is not a great idea because you have to rebuild everything from scratch and summaries eat up significant amounts of space) or search without the summariesonly=true option (which will be much more intensive since you'll have to search through all the raw data fitting the dataset conditions.

Both solutions have their pros and cons.

0 Karma

mlm
Explorer

@PickleRick my post got deleted lol.

 

Could you tell me please what the possible change would be to capture those previous months data without tampering what I have now? Basically, I just want to fill the gaps for previous months for reporting purposes 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...

SPL2 Deep Dives, AppDynamics Integrations, SAML Made Simple and Much More on Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...