Splunk Search

Why is Datamodel=Authentication not getting older events?

mlm
Explorer

Hey gents,

 I am very new to splunk but does anyone have an idea why my search from datamodel=authentication not getting older events (say last month or two)? Below is my search string:

| tstats prestats=true summariesonly=true allow_old_summaries=true count from datamodel=Authentication.Authentication where Authentication.app=win* Authentication.action=* by _time, Authentication.action span=10m
| timechart minspan=10m useother=true count by Authentication.action



Any suggestion would be so much appreciated! 


Cheers 

Labels (2)
0 Karma

PickleRick
SplunkTrust
SplunkTrust

You can either disable acceleration, change the summary range and rebuild the summaries (which is not a great idea because you have to rebuild everything from scratch and summaries eat up significant amounts of space) or search without the summariesonly=true option (which will be much more intensive since you'll have to search through all the raw data fitting the dataset conditions.

Both solutions have their pros and cons.

0 Karma

mlm
Explorer

@PickleRick my post got deleted lol.

 

Could you tell me please what the possible change would be to capture those previous months data without tampering what I have now? Basically, I just want to fill the gaps for previous months for reporting purposes 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas     Cisco Live 2026 is almost here, and this ...

What Is the Name of the USB Key Inserted by Bob Smith? (BOTS Hint, Not the Answer)

Hello Splunkers,   So you searched, “what is the name of the usb key inserted by bob smith?”  Not gonna lie… ...

Automating Threat Operations and Threat Hunting with Recorded Future

    Automating Threat Operations and Threat Hunting with Recorded Future June 29, 2026 | Register   Is your ...