Splunk Search

Why does the search works in Monitoring Console but not in other Apps?

jorcabro
Explorer

I'm trying to convert the Health Check queries into a dashboard, I already change neccesary permissions in some macros and lookups in order to do this but two of the searches launch this kind of query:

`dmc_set_index_internal` splunk_server=local search_group=dmc_group_indexer

This search works in Monitoring Console but not in other searches.
As I said the macro is already permitted and working but the Field search_group does not exist in other apps.
I've tried to find it in Field aliases, Calculated fields, fields extractions, etc... but not luck.

I don't know where else this could be.
Any idea?

Thanks.

0 Karma
1 Solution

DavidHourani
Super Champion

Hi @jorcabro,

The field search_group is the result of a lookup. You can find it in props.conf :

LOOKUP-dmc_add_instance_info = dmc_assets host OUTPUTNEW machine search_group

You can change that lookup's permission to global in order to use it in another app because by default it's not exported anywhere :

[]
export = none
access = read : [ admin ], write : [ admin ]

Cheers,
David

View solution in original post

DavidHourani
Super Champion

Hi @jorcabro,

The field search_group is the result of a lookup. You can find it in props.conf :

LOOKUP-dmc_add_instance_info = dmc_assets host OUTPUTNEW machine search_group

You can change that lookup's permission to global in order to use it in another app because by default it's not exported anywhere :

[]
export = none
access = read : [ admin ], write : [ admin ]

Cheers,
David

View solution in original post

jorcabro
Explorer

Hi David,

Thanks for your answer.
I'm not sure I'm understanding the syntaxis but the lookup dmc_assets is already in global. If I do an

| inputlookup assets.csv

is working.
I also see the

LOOKUP-dmc_add_instance_info =
dmc_assets host OUTPUTNEW machine
search_group

line props.conf inside monitoring console app. Is it possible that this line should be also in the other apps so they can do the enrichement?

Regards,

Jorge

0 Karma

DavidHourani
Super Champion

Hi @jorcabro,

You shared the permissions for the lookup itself, not the automatic lookup configuration, so you can see the lookup when running inputlookup, but the field doesn't get automatically added when you're not in the MC.

You can either move that line to the app that requires the extra field, or share it globally from the automatic lookup settings ^^

Cheers,
David

jorcabro
Explorer

Alright! Now is working!
Thanks for your help.

Regards,

Jorge

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.