Splunk Search

Why do these two searches return different results for page views?

pladamsplunk
Explorer

I've downloaded an application for web analytics, however on two separate dashboards it shows two difference values for "pageviews" which I would think should be consistent throughout the data. The two searches for page views are the following.

| tstats summariesonly=t max(Web.http_session_pageviews) FROM datamodel=Web WHERE Web.site="*" "Web.eventtype"=pageview GROUPBY Web.http_session

....this search produces the value 60,000

| tstats summariesonly=t count(Web.http_session_pageviews) FROM datamodel=Web WHERE Web.site="*" "Web.eventtype"=pageview GROUPBY Web.http_session

... this search produces the value 230,000

Can anyone help me understand the difference between these two searches and why they are returning different values (even though I believe they should be returning the same value since pageviews in the data is a constant value) ?

Tags (3)
0 Karma

sundareshr
Legend

The difference is between max and count. The first query is returning the max value in http_session_pageviews field, whereas the second query is returning the count of events.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Agent Mode Engaged! Enchaining Agentic Operations with Splunk AI Assistant 2.0

    Are you ready to transform how your team handles complex data requests? We invite you to our upcoming ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...