Splunk Search

Why are fields getting trimmed while fetching?

Nidd
Path Finder

I have some error logs like below:

 

 

TYPE=ERROR, DATE_TIME=2022-12-31 03:30:27,281, CLASS_NAME=myClass, METHOD_NAME=myMethod, message=unknown error while fetching recordsjavax.net.ssl.SSLHandshakeException: General SSLEngine problem
TYPE=ERROR, DATE_TIME=2023-01-19 00:38:09,013, CLASS_NAME=myClass, METHOD_NAME=myMethod, message=unknown error while fetching recordsjava.lang.IllegalStateException: could not create the default ssl context

 

 

I need to get the message field of these logs and to sort them based on _time. I am trying the below queries to get the same.

Query 1:

 

 

index="myIndes" host=myHost source="/my/app/location/app.log" TYPE=ERROR | extract pairdelim=",|" kvdelim="=" | table message | sort _time

 

 

Query 2:

 

 

index="myIndes" host=myHost source="/my/app/location/app.log" TYPE=ERROR | rex "^(?:(?<message>[^,]*),){7}" | table message | sort _time

 

 

But for both these queries, my response looks like below. Instead of getting the entire message field, I am getting just the first word.

 

 

--------
message
--------
unknown

 

 

Please help on how to achieve this.

Labels (3)
0 Karma

scelikok
SplunkTrust
SplunkTrust

Hi @Nidd,

You can use below query;

index="myIndes" host=myHost source="/my/app/location/app.log" TYPE=ERROR 
| rex "message=(?<message>.+)" 
| table message 
| sort _time

 

If this reply helps you an upvote and "Accept as Solution" is appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...