Splunk Search

Web datamodel contains negative values for bytes ingested from Umbrella proxylogs

nagamadhupriyan
Loves-to-Learn Lots

The Web datamodel contains negative values for bytes ingested from Umbrella proxylogs

below is the query that we are using for the search

| tstats `summariesonly` sum(Web.bytes_out) as size_out, sum(Web.bytes_in) as size_in, values(Web.http_method) as method
from datamodel=Web.Web by Web.user,Web.url, _time span=1d
| `drop_dm_object_name("Web")`

Labels (2)
Tags (1)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @nagamadhupriyan ,

you should see how Datampdel is populated, maybe it uses a wrong field or a wrong field extraction.

Ciao.

Giuseppe

0 Karma

nagamadhupriyan
Loves-to-Learn Lots

Hi 

 

byte field :case(isnum(bytes),bytes,isnum(bytes_in) AND isnum(bytes_out),
bytes_in+bytes_out,1=1,null())
  

 

 

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Skip the Awkward Silence: Have a .conf-ersation at .conf26

Picture this. You arrive at .conf26 already having your socializing and networking plans mapped out. No ...

Rethinking Zero Trust: From Product Purchases to Logical Control Evidence

Implementing Zero Trust (ZT) across complex environments often falters at the very beginning due to a ...