Splunk Search

Using the Splunk Tutorial data, how to edit my search to calculate the cart to purchase percentage by productId?

rishabh4
New Member

Using eval command, how would I calculate the cartToPurchase percentage by product?

sourcetype=access* status=200 action= purchase OR view  | stats count(eval(match("purchase cart"))) AS carttopurchase |stats count AS total | eval percent=(carttopurchase/total)*100 

Please help me to execute the search and please don't close this question as i am in serious need for the answer.

0 Karma
1 Solution

somesoni2
Revered Legend

Try like this

sourcetype=access_* status=200 | chart count(eval(action="addtocart")) AS addtocart count(eval(action="purchase")) AS purchases by productName | eval percent=(purchases/addtocart )*100 

View solution in original post

0 Karma

somesoni2
Revered Legend

Try like this

sourcetype=access_* status=200 | chart count(eval(action="addtocart")) AS addtocart count(eval(action="purchase")) AS purchases by productName | eval percent=(purchases/addtocart )*100 
0 Karma

skoelpin
SplunkTrust
SplunkTrust

Can you close out the other question you asked (Accept an answer) which is very similar to this one?

0 Karma

rishabh4
New Member

bro please help in this question i need to calculate the percentage and also for % i need to calculate the arguments for it.
help

0 Karma

rishabh4
New Member

please answer here brother please i need it

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...