Splunk Search

Transaction function not working with dbquery


Hi All,

I tried using the transaction function on the output of a DB Connect |dbquery and it keeps showing no results.

So my data is like this:

Date      ID Status 
2014/05/12 1 Created
2014/05/12 2 Created
2014/05/12 2 Processing
2014/05/12 1 Processing
2014/05/13 1 Completed
2014/05/13 2 Completed

When I do something like |dbquery <SQL query to get data in above given format>|transaction Status

it returns as no records found.

Kindly provide guidance on this.

Tags (2)
0 Karma


What do you get if you just do this:

|dbquery <SQL query to get data in above given format>

Plus, it seems strange to me that you would create a transaction based on Status - what are you trying to do?

0 Karma


Hello lguinn,

Thanks you for your reply. The output I gave in the OP is my result set from the SQL query. The transaction should take into account both the ID and the Status. But I tried this in the DB connect app and it still does not work. Is it that the transaction function can only be used in the Search app?

0 Karma
Get Updates on the Splunk Community!

Dashboard Studio Challenge - Learn New Tricks, Showcase Your Skills, and Win Prizes!

Reimagine what you can do with your dashboards. Dashboard Studio is Splunk’s newest dashboard builder to ...

Introducing Edge Processor: Next Gen Data Transformation

We get it - not only can it take a lot of time, money and resources to get data into Splunk, but it also takes ...

Take the 2021 Splunk Career Survey for $50 in Amazon Cash

Help us learn about how Splunk has impacted your career by taking the 2021 Splunk Career Survey. Last year’s ...