Splunk Search

Total occurrences within a column

dmarcantonionw
Engager

I am pulling Windows event logs for software updates. There's a column for successRatio that is either Success or Failure as the result. I would like to append my event log search query to give me a total number of Success and total number of Failure. Bonus points if we can make it a numerical value on a dashboard. Here is my initial search query:

index=wineventlog sourcetype=WinEventLog:System EventCode=19  | eval Date=strftime(_time, "%Y/%m/%d") | rex "\WKB(?<KB>.\d+)\W" | eval successRatio=mvindex(split(Keywords,","),-1) | stats count by Date , host, package_title, KB , body , successRatio| sort host

This works great, but like I said, I'd like to have a total count of success and failures available in a report and a dashboard.

0 Karma

mayurr98
Super Champion

hey Try this

index=wineventlog sourcetype=WinEventLog:System EventCode=19 
| eval Date=strftime(_time, "%Y/%m/%d") 
| rex "\WKB(?<KB>.\d+)\W" 
| eval successRatio=mvindex(split(Keywords,","),-1) 
| stats count(eval(successRatio="Success")) as "Success_Count" count(eval(successRatio="Failure")) as "Failure_Count" by Date , host, package_title, KB , body 
| sort host

let me know if this helps!

0 Karma

adonio
Ultra Champion

Hello there,

please try out this search:

  index=wineventlog sourcetype=WinEventLog:System EventCode=19 
    | eval Date=strftime(_time, "%Y/%m/%d") 
    | rex "\WKB(?<KB>.\d+)\W" 
    | rex field=Keywords "\w+,\s+(?<status>\S+)"
    | stats count(eval(status="Success")) as succeeded count(eval(status="Failure")) as failed

from here you can take it however you would like

hope it helps

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...