Splunk Search

Subsearch using boolean logic

bluemarvel
Path Finder

Hello, I am looking for a search query that can also be used as a dashboard.
The query has to search two different sourcetypes , look for data (eventtype,file...etc.) and if the information is missing in one sourcetype and found in another, then it will provided that data for that sourcetype.

Tags (1)
1 Solution

skoelpin
SplunkTrust
SplunkTrust

You can use a case statement to do this

... | eval Your_field=case(sourcetype == sourcetype1, "true", sourcetype == sourcetype2, "true" , 1=1, "false")

http://docs.splunk.com/Documentation/Splunk/6.4.2/SearchReference/CommonEvalFunctions

View solution in original post

somesoni2
Revered Legend

Could you be more specific in your requirement, supported with sample queries/events and expected output?

0 Karma

skoelpin
SplunkTrust
SplunkTrust

You can use a case statement to do this

... | eval Your_field=case(sourcetype == sourcetype1, "true", sourcetype == sourcetype2, "true" , 1=1, "false")

http://docs.splunk.com/Documentation/Splunk/6.4.2/SearchReference/CommonEvalFunctions

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...