Splunk Search

Subsearch Help

richardphung
Communicator

I have the following search:

index="*" sourcetype=endpoints [search index="*" signature="sig_id" | dedup dest | fields dest ]

Which produces no results.

Doing each of these, independently works...
For example, the subsearch:

index="*" signature="sig_id" | dedup dest | fields dest

gives me a nice stats table with hostname_1, hostname_2, etc.

And if I manually define this in the main search:

 index="*" sourcetype=endpoints hostname_1

I get all of my events.

Tags (1)
0 Karma
1 Solution

woodcock
Esteemed Legend

You should always use | format at the end of your subsearch so that you can see what it is creating. If you had done so, you would have seen that your subsearch is using the field name in the SPL that it generates (like dest="value"). Based on your test search, you need just the value so try this:

index="*" sourcetype=endpoints [search index="*" signature="sig_id" | dedup dest | fields dest | format "(" "" "" "" "OR" ")" | rex field=search mode=sed "s/dest=//g"]

View solution in original post

yassinesakri
Engager

Hi guys, I hope I can borrow your fantastic brains on this one, I have the same concept, I want to check the top failed ip that authenticated afterwards:

<search_for_authenticated_users> ip [<search_for_failed_user>| top limit=100 client_ip | rename clientip AS ip | table ip ] | top  user ip

I hope someone can shed some light, or direct me somewhere where some else has faced the same problem.

0 Karma

woodcock
Esteemed Legend

You should always use | format at the end of your subsearch so that you can see what it is creating. If you had done so, you would have seen that your subsearch is using the field name in the SPL that it generates (like dest="value"). Based on your test search, you need just the value so try this:

index="*" sourcetype=endpoints [search index="*" signature="sig_id" | dedup dest | fields dest | format "(" "" "" "" "OR" ")" | rex field=search mode=sed "s/dest=//g"]

richardphung
Communicator

This is a great tip.

0 Karma

richardphung
Communicator

Figured it out...
the field dest doesn't exist in the main search.. need to rename field:

index="*" sourcetype=endpoints [search index="*" signature="sig_id"  | dedup dest 
    | rename dest AS client_name | table client_name]

woodcock
Esteemed Legend

It is OK to keep the | format in your search, like this:

index="*" sourcetype=endpoints [ search index="*" signature="sig_id"  | dedup dest | rename dest AS client_name | table client_name | format ]
0 Karma

whrg
Motivator

So your subsearch produces a field named "dest". Is there a "dest" field (containing hostname_1, hostname_2, etc.) available in the primary search?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...

SplunkTrust Application Period is Officially OPEN!

It's that time, folks! The application/nomination period for the 2026-2027 SplunkTrust is officially open. If ...