Splunk Search

Splunk not able to recognize the JSON file source type and index it

vikrantkumar199
New Member

I am trying to monitor a folder containing JSON files in it. But, I observed that files are not getting indexed.
When looked into *, the "Number of files" getting updated as new files get added.
But in *'Indexes'
section, "Event Count" remain same 0 and does not increase.
Tried to even search with index="index_name", it does not return any result and shows 0 events.
Even checked the validity of the JSON file on multiple sites and found valid.
Tried to reduce the JSON size as well. Still no luck.

Any suggestion or clue to debug is highly appreciated!
Thanks in advance.

0 Karma

woodcock
Esteemed Legend
0 Karma
Get Updates on the Splunk Community!

Streamline Data Ingestion With Deployment Server Essentials

REGISTER NOW!Every day the list of sources Admins are responsible for gets bigger and bigger, often making the ...

Remediate Threats Faster and Simplify Investigations With Splunk Enterprise Security ...

REGISTER NOW!Join us for a Tech Talk around our latest release of Splunk Enterprise Security 7.2! We’ll walk ...

Introduction to Splunk AI

WATCH NOWHow are you using AI in Splunk? Whether you see AI as a threat or opportunity, AI is here to stay. ...