Splunk Search

Splunk Search: Lateral Movement

johann2017
Explorer

Hello! I am wanting to build a search that can help detect lateral movement. I want to see when the same user is logging into multiple machines in a specific period of time. For example, an admin account gets compromised. That same admin account was then used to log into 50 different computers in the course of an hour. How would I run a search similar to something like that?

Tags (1)
0 Karma

sduff_splunk
Splunk Employee
Splunk Employee

Something like the following would count the number of unique hostnames ( dc = distinct count) that the Admin has logged into.

index=wineventlog Logon user=Administrator earliest=-65m@m | stats dc(hostname), values(hostname)

You may also want to look at the Security Essentials app, https://splunkbase.splunk.com/app/3435/ , which hassome examples of such searches and use-cases.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Build resilience for the agentic era: Join us at Splunk Go San Jose

AI is changing how organizations build, operate, and secure digital services. As teams adopt AI agents and ...

Manage Edge Processor pipelines end to end with APIs

This guide uses the Data Management APIs to create an Edge Processor, onboard one instance, deploy a pipeline ...