Splunk Search

Splunk ES - Notable events not throttled

lpino
Path Finder

Hi all,

I have a Correlation Search that generates notable events ignoring the throttling configuration.
The search is "Excessive Logins Failed" and is set with the current parameters:

Cron schedule: */20 * * * *
Time range: from '-65m' to 'now'
Scheduling: continuous
Schedule Window: No Window
Scheduling priority: Default
Trigger condition: number of results > 0
Throttling window: 86400 seconds
Throttling fields to group by: src

The search is the following:

 

| tstats summariesonly=true allow_old_summaries=true dc(Authentication.user) as "user_count",dc(Authentication.dest) as "dest_count",count from datamodel="Authentication"."Authentication" where Authentication.user!=*$ nodename="Authentication.Failed_Authentication" by "Authentication.app","Authentication.src" 
| `drop_dm_object_name(Authentication)` 
| replace "::ffff:*" with "*" in src
| where count>=500 

 


Search runtime is very short (few seconds), so I'm sure there are no overlapping searches at the same time.
Nevertheless, I often find notable events generated for the same 'src' in the last 24 hours. I also have another Correlation Search (Brute Force Attacks detection) which have similar configuration/scheduling but in this case the throttling is working fine.

Can anyone help me with this? Anybody else having the same issue?

Thanks in advance

0 Karma

lpino
Path Finder

Now I'm experiencing the same issue for other correlation searches as well.

Is there anybody else having the same behavior?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas     Cisco Live 2026 is almost here, and this ...

What Is the Name of the USB Key Inserted by Bob Smith? (BOTS Hint, Not the Answer)

Hello Splunkers,   So you searched, “what is the name of the usb key inserted by bob smith?”  Not gonna lie… ...

Automating Threat Operations and Threat Hunting with Recorded Future

    Automating Threat Operations and Threat Hunting with Recorded Future June 29, 2026 | Register   Is your ...