Splunk Search

Search using two indexes

moayadalghamdi
Path Finder

Hola Splunkers !!

 

i want to search in two indexes with one common values in between, for exapmle:

 

index=Exchange_server has the following fields: sender, subject

index=EmailProxy has the following fields: src_ip, sender

 

where the sender value is the same in the two indexes 

 

 

i want the output to conclude: src_ip, SenderMail,  Subject

 

here's my search:

index=Exchange_server OR index=EmailProxy | table src_ip message_subjec sender

moayadalghamdi_0-1622103988354.png

 

 

but unfortunately i got many blank fields, please help me with it.

 

 

Thanks^_^

 

 

 

Labels (4)
0 Karma

aasabatini
Motivator

Hi @moayadalghamdi 

try this

index=msexchange OR index=cisco_esa | stats  values(message_subject) as message_subject values(sender) as sender by src_ip
“The answer is out there, Neo, and it’s looking for you, and it will find you if you want it to.”
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...