Splunk Search

Search using two indexes

moayadalghamdi
Path Finder

Hola Splunkers !!

 

i want to search in two indexes with one common values in between, for exapmle:

 

index=Exchange_server has the following fields: sender, subject

index=EmailProxy has the following fields: src_ip, sender

 

where the sender value is the same in the two indexes 

 

 

i want the output to conclude: src_ip, SenderMail,  Subject

 

here's my search:

index=Exchange_server OR index=EmailProxy | table src_ip message_subjec sender

moayadalghamdi_0-1622103988354.png

 

 

but unfortunately i got many blank fields, please help me with it.

 

 

Thanks^_^

 

 

 

Labels (4)
0 Karma

aasabatini
Motivator

Hi @moayadalghamdi 

try this

index=msexchange OR index=cisco_esa | stats  values(message_subject) as message_subject values(sender) as sender by src_ip
“The answer is out there, Neo, and it’s looking for you, and it will find you if you want it to.”
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Casting Call: Compete in Cyber Games

Lights, Camera, SecOps: Apply to Compete in Cyber Games     Think you have what it takes to beat the clock? ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

How Edge Processor's Durable Queue Works

Edge Processor sits in one of the most consequential places in any Splunk pipeline: between your data sources ...