Splunk Search

Search events for multiple samaccountnames

papa
Explorer

Hello 

Cam someone assist on how to do a search like below for multiple samaccountnames ? 

ideally from a txt file or CSV ? so to reference the file in the search . 

 

 

 

<SamAccountName> EventCode=4624 | table _time,EventCode,src,user,Logon_Type

 

 

Labels (1)

inventsekar
SplunkTrust
SplunkTrust

Hi @papa , As @renjith_nair suggested, the lookup is one idea. or if you already ingested the 
multiple samaccountnames csv files to splunk, then, you can simply query the multiple files altogether.  my apologies if you already know this method. 

index=indexName <multiple-SamAccountNames> EventCode=4624 | table _time,EventCode,src,user,Logon_Type
0 Karma

renjith_nair
Legend

Try

index="your index" EventCode=4624 [|inputlookup SamAccountName.csv|fields SamAccountName] 

This should create an OR'd list of SamAccountName

---
What goes around comes around. If it helps, hit it with Karma 🙂
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...

Design, Compete, Win: Submit Your Best Splunk Dashboards for a .conf26 Pass

Hello Splunkers,  We’re excited to kick off a Splunk Dashboard contest! We know that dashboards are a primary ...

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...