Splunk Search

Return command giving error for stats c(eval...) in splunk

snehalk
Communicator

Hello Everyone,

Am creating the dynamic query depending on condition and after that using return command to execute that search query string, below is my search query

   [ | search query which gives me dynamic string.... | return $myquery ]

where $myquery contain index=xyz | stats c(eval(eventtype="myeventtype1")) as "myeventtype1", c(eval(eventtype="myeventtype2")) as "myeventtype2"

but its giving me the error (actually its putting the each eventtype value while executing), is there any way where we can execute this query without any error?

Note: when i execute myquery string manually its perfectly working fine.

Can any on help me here?

Thank you

0 Karma

woodcock
Esteemed Legend

Why bother with the extra stuff; just do this ( search is a special field name returning from subsearches):

  [ | search query which gives me dynamic string.... | rename myquery AS search ]
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...