Splunk Search

Reordering columns not working through API

whateverwhouare
New Member

I want to reorder my columns. I tried both table and fields, and they seemed to work through the web UI, but when I tried it through the REST API the order did not change at all.

Is there any known problem with reordering through REST API, or can anyone point out what I'm doing wrong? Below is my query.

index=na1 host=*app* logRecordTypeseclk=1 earliest=-5h tableEnumOrId=Contact OR tableEnumOrId=CollaborationGroup | where rank < 10 | stats count by rank, tableEnumOrId | table count, tableEnumOrId, rank

EDIT:

I asked this a while ago but I think the issue is somehow stats is affecting table. When I change stats count by rank, tableEnumOrId to stats count by tableEnumOrId, rank, the output order changed accordingly. But no matter how I change the ordering of the column names in table, nothing changes.

Is this a known issue? Or am I just doing something wrong?

0 Karma

nicolas_perreau
Explorer

Hi!

I'm having the same issue with REST and I do not see anyway to fix it so far.

I've just upgraded from Splunk 5.0.5 to 6.2.2 and noticed the behavior.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...