Splunk Search

Query question between 2 indexes

christay
New Member

Hi Guys,

Can i check how can i craft the query given the following condition.

I have 2 indexes IndexA and IndexB with the following filed in each index.

Example as follows :

IndexA

Field contains :

srcIP = 10.10.10.10
cat = malicious IP 100%

IndexB

Field contains  :

TrueClientIP = 10.10.10.10

The objective of my query is to compare "TrueClientIP" under Index B against "srcIP" under IndexA and the condition that if the "cat" field under IndexA is tag under malicious IP it will return me the count .

How can i craft the above query ?

Thanks for the help.

 

0 Karma

to4kawa
Ultra Champion

index=IndexA OR index=IndexB | eval ip=coalesce(srcIP,TrueClientIP) | rex field=cat "(?<malicious>malicious)" | stats count(malicious) by ip

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...