Splunk Search

Problem with timechart after a join

gferrazzano
New Member

My base search is just building a timechart of 3 utilization rates over time. Two rates come from one source, one from another via a join. Seems to work fine.

index=XXXX sourcetype="XXXX"
| eval Booked_tilization=substr(BookedUtilization , 1, len(BookedUtilization )-1)
| eval mytime=strptime(MonthYear, "%m/%d/%Y")
| eval _time=mytime
| eval "Room GUID"=substr(SynergyID , 1, len(SynergyID )-10)
| lookup XXXXXX.csv "Room GUID"
| join type=outer "System Name" [search index=XXXX sourcetype="XXXXX" | rename "Endpoint Name" as "System Name"]
| timechart span=1mon eval(round(avg(BookedUtilization),2)) as "Booked Utilization %" eval(round(avg(PanelUtilization),2)) as "Panel Utilization %" eval(round(avg('Utilization Rate'),2)) as "VC Utilization %"

alt text

However, if I specify a room number, the first two still work but the third breaks and gives you a repeating number. The number it gives (36.85) is the average for that room over all months.

alt text

Any guidance is appreciated!

Tags (1)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...